U

Visitor

 • 

4 Messages

Tue, Aug 9, 2022 2:00 AM

Is Xfinity blocking my DNS responses?

For some reason, when my computer is connected to the internet via my Xfinity home WiFi connection, and using the DNS configuration that was automatically configured, I cannot do any DNS lookups for my domain, (foxcove.com).

On other networks, the same DNS lookup ("dig foxcove.com") returns the expected information.

I did recently (a few hours ago now) find that a site called spfbl.com had he domain on a blacklist, but I followed the procedure for clearing that, and they say it was successfully removed from their list. I was hoping that might do the trick, but the Xfinity DNS servers still won't return DNS records for the domain.

Things were working OK until a few days ago.

Can somebody shed any light on what might be going on?

Thanks,

  - Richard

Accepted Solution

Visitor

 • 

4 Messages

2 m مضت

Ah, I just updated the registry level DNSSEC records for the domain, and now the lookups from CloudFare and Google are succeeding. I'm going to presume that the Comcast servers just do some sort of update less frequently and will soon come around.

Just another of the ever increasing challenges of hosting one's own email server these days, caught in the crossfire of the SPAM wars.

I've come a long way since were were doing FORTRAN programming on punch cards in high school ca. 1974. Didn't have to update DNSSEC records to the register every year back then.

BruceW

Gold Problem Solver

 • 

24K Messages

2 m مضت

... I cannot do any DNS lookups for my domain, (foxcove.com) ...

It isn't just Comcast. Of the four DNS servers I tried, Level3 is the only one that returned an IP for foxcove.com:

C:\>nslookup foxcove.com 1.1.1.1  (Cloudflare)
*** one.one.one.one can't find foxcove.com: Server failed

C:\>nslookup foxcove.com 8.8.8.8  (Google)
*** dns.google can't find foxcove.com: Server failed

C:\>nslookup foxcove.com 75.75.75.75  (Comcast)
*** cdns01.comcast.net can't find foxcove.com: Server failed

C:\>nslookup foxcove.com 4.2.2.2  (Level3)

Server:  b.resolvers.Level3.net
Non-authoritative answer:
Name:    foxcove.com
Address:  54.148.162.81

That IP is displaying an "Apache2 Ubuntu Default Page".

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

(edited)

Visitor

 • 

4 Messages

2 m مضت

Thanks for your comment Bruce.

> That IP is displaying an "Apache2 Ubuntu Default Page".

That's true. But the server does name based virtual hosts for several domains, e.g., rocks.foxcove.com. I could make it serve something other than the default page, if you are suggesting that the default page explains why three of the four servers you tried returned "server failed".

Are you familiar with the spfbl.net blacklist? I'm not sure whether the domain's presence on the list is connected with why many DNS servers fail to return information for the domain. I'll check the servers you showed again now, in case the blacklist entry was, indeed, the problem - perhaps the removal take time to propagate somehow?

Again thanks for your comment and help!

  - Richard

Visitor

 • 

4 Messages

2 m مضت

PS. Yep, the Comcast servers have now confessed to knowing about the domain.

forum icon

New to the Community?

Start Here